BGP/MPLS-VPN中的MCE技术

2019-11-13 19:19:44 云杰通信 101


传统的BGP MPLS VPN中,PE设备连接CE设备时,如果CE设备下只有一个VPN,那么CE设备不需要隔离业务的网段,CE下连接的私网业务段就存在于IP路由表中,此时没有什么问题。但是如果CE下同时存在多个VPN,那么不同vpn的路由就需要在CE设备的路由表中做区分了。此时可以采用MCE技术实现。MCE(Multi-VPN-Instance CE,多实例CE)通过多实例在CE设备上提供逻辑独立的VPN路由实例和地址空间,使多个不同VPN下的用户可以共享一个CE。MCE以较低的成本解决了局域网的业务隔离和安全问题,提供了新的、经济的、管理简化的解决方案。今天的技术帖我们就给大家介绍MCE技术的配置。

拓扑图如下图所示:

BGP/MPLS-VPN中的MCE技术

一、需求:

MCE1上连接两个VPN,VPN1和VPN2,在MCE1上配置MCE技术,隔离两个VPN实例的路由信息。

二、配置:

[MCE1]ip vpn-instance vpn1----创建VPN实例

[MCE1-vpn-instance-vpn1]route-distinguisher 100:1----配置RT值

[MCE1-vpn-instance-vpn1]vpn-target 100:1----配置RD值

[MCE1]ip vpn-instance vpn2

[MCE1-vpn-instance-vpn2]route-distinguisher 200:1

[MCE1-vpn-instance-vpn2]vpn-target 200:1

[MCE1]interface LoopBack 1

[MCE1-LoopBack1]ip binding vpn-instance vpn1----把私网接口绑定到VPN实例,路由加入到VPN实例的路由表中

Some configurations on the interface are removed.

[MCE1-LoopBack1]ip address 192.168.1.1 32

[MCE1]interface LoopBack 2

[MCE1-LoopBack2]ip binding vpn-instance vpn2

Some configurations on the interface are removed.

[MCE1-LoopBack2]ip address 192.168.2.1 32

[MCE1]interface g0/0.10----因为PE1连接MCE1只有一个物理接口,承载两个VPN,所以创建子接口

[MCE1-GigabitEthernet0/0.10]ip binding vpn-instance vpn1

Some configurations on the interface are removed.

[MCE1-GigabitEthernet0/0.10]ip address 10.1.1.2 24

[MCE1-GigabitEthernet0/0.10]vlan-type dot1q vid 10----给子接口打上vlan标记

[MCE1]interface GigabitEthernet 0/0.20

[MCE1-GigabitEthernet0/0.20]ip binding vpn-instance vpn2

[MCE1-GigabitEthernet0/0.20]ip address 10.2.2.2 24

[MCE1-GigabitEthernet0/0.20]vlan-type dot1q vid 20

配置成功之后查看VPN实例的路由表:

BGP/MPLS-VPN中的MCE技术

BGP/MPLS-VPN中的MCE技术

此时发现vpn1和vpn2的路由分别会属于VPN实例的路由表中。